[OpenWalnut-Dev] Renamed WGUI to WUI and similar

Alexander Wiebel wiebel_openwalnut at dergrosse.de
Mon Jan 27 15:15:20 CET 2014


Hi fellow developers,
we are changing the API a little bit to adjust some names to what the
classes actually represent. In particular, we are changing some names
from GUI (graphical user interface) to UI (user interface) where no
graphics stuff is involved.

Our first step consisted of the following changes:
(1) renamed directory "core/gui" to "core/ui"
(2) renamed class WGUI to WUI
(3) changed name of "getGui" in WKernel to "getUI" and its return type
to shared_ptr to WUI
(4) changed signature of WKernel::instance
(5) changed signature of protected WKernel-Constructor

These changes might make the following changes necessary in your code
(if it is not in one of the public repositories):

(1)
- change any include referring to a file in "core/gui" --> "core/ui"
(2)
- change any include referring to "WGUI.cpp" or "WGUI.h" to "WUI.cpp" or
"WUI.h"
- change all inheritance referring to "WGUI" to "WUI"
- appropriately adapt the _type_ and _name_ of all variables holding
references to "WGUI"
(3)
- Adapt all code using "WKernel::getGui(...)" to use "WKernel::getUI"
instead
(4)
- Adapt all code using "WKernel::instance(...)" to use "WUI" instead of
"WGUI" in its parameters.
(5)
- If you _derived_ from WKernel adapt the constructor calls to use "WUI"
instead of "WGUI"

Please also take a look at the comments and documentation related to
your changes.

A similar change related to WScriptGUI will follow soon.

If you have any questions or problems regarding this API change please
do not hesitate to contact me or the list.

Cheers
Alex


More information about the OpenWalnut-Dev mailing list